Involved Account Creation Process

Hello!

I am a new member on this forum and wanted to leave a little feedback about the signup process. I want to preface that by saying that I am very grateful you all are providing this forum service (and not using a facebook group!) to the community for free! I have been wanting to use discourse for a variety of community groups for a while so it’s nice to see a working example here.

I was able to make an account, but I wanted to mention that the process was a bit cumbersome.

I found out about this forum through signing up for an event and the email list:

Screen Shot 2022-08-16 at 11.13.56 AM|376x499

When I got to the forum, I liked “Log In” and then “Register”. At this point, the “submit” button was missing. I was able to still submit by hitting return after filling out the username and email:

Screen Shot 2022-08-16 at 11.11.00 AM|397x500

1 Like

Second, after I filled that out, I got an email which led me to a password link:

Screen Shot 2022-08-16 at 11.12.02 AM|690x240

However, when I clicked that link, it said it was an invalid code or something, so then I had to do a password reset. I then got a password reset email:

Screen Shot 2022-08-16 at 11.12.51 AM|690x364

I was able to follow that to reset my password. Then I had to find the forum link again and click login in. When I logged in, this sent me another email to confirm my forum account:

Screen Shot 2022-08-16 at 11.15.38 AM|690x348

After following this link, my account was confirmed and I am able to make my first post here!


So in summary, after clicking the link on the forum, I had to click on three different email links to create my account. If this signup process happens to other people, it might cause them to give up halfway.

I also wonder if you might consider supporting a single sign on service as well as logging in with a sociocracy for all account, so that folks with an existing, say, Google, account could use that, to get started more easily on the forum.

Anyways, thanks again for hosting and supporting this free forum and I look forward to following allow the community here!

Also note that I was not able to include the screenshots as images, when trying to, I got a “Sorry, you can’t embed media items in a post.” error, so I have included them as links. I am also only allowed to include 2 links in my post, so I broke it up into multiple comments.

Thanks for sharing your experience! This is helpful, we’ll review the registration process and make sure things like the submit button are visible! That’s pretty key!

I believe most users wind up registering through other pages, but considering the forum brings you through that avenue, it should be working!

I suspect a recent security addition of the captcha button messed that up the page display and you’re the first to notice (and report it - thank you!)

We’ll also look into changing the way passwords are set to see if we can reduce the number of emails.

We will also explore a Single Sign on option. We havne’t implimented this in the past, but it does seem like it would help folks!

I don’t know what we’ll remove the email confirmations though, as that’s an important step to avoid spam and make sure people receive emails in the right inbox.

We’ll follow up here with updates once we address these issues! Thanks again for reporting!

CJ O’Reilly
Technical Support
Sociocracy for All

1 Like